aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-07-17 19:35:04 +0200
committerKarel Kočí <cynerd@email.cz>2022-07-17 19:35:04 +0200
commit482566b84fc9b30538ae4dd090e77a0979aa1a3f (patch)
tree16a9819851b9fda2fcf45698c38f6b63eeb58228 /flake.nix
parentb106528fd8db5f1004b5559b742c2f2825e39940 (diff)
downloadnixturris-482566b84fc9b30538ae4dd090e77a0979aa1a3f.tar.gz
nixturris-482566b84fc9b30538ae4dd090e77a0979aa1a3f.tar.bz2
nixturris-482566b84fc9b30538ae4dd090e77a0979aa1a3f.zip
nixos: allow tarball build and cross-build directly
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index e65ae2a..ad1be3e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -15,8 +15,8 @@
lib = import ./lib { inherit self; nixpkgsDefault = nixpkgs; };
nixosConfigurations = {
- tarballMox = self.lib.nixturrisTarballSystem { board = "mox"; nixpkgs = nixpkgs; };
- tarballOmnia = self.lib.nixturrisTarballSystem { board = "omnia"; nixpkgs = nixpkgs; };
+ mox = self.lib.nixturrisSystem { board = "mox"; nixpkgs = nixpkgs; };
+ omnia = self.lib.nixturrisSystem { board = "omnia"; nixpkgs = nixpkgs; };
};
} // eachSystem supportedHostSystems (
@@ -26,11 +26,11 @@
tarball = nixos: nixos.config.system.build.tarball;
in {
- tarballMox = tarball self.nixosConfigurations.tarballMox;
- tarballOmnia = tarball self.nixosConfigurations.tarballOmnia;
+ tarballMox = tarball self.nixosConfigurations.mox;
+ tarballOmnia = tarball self.nixosConfigurations.omnia;
- crossTarballMox = tarball (self.lib.nixturrisTarballSystem { board = "mox"; nixpkgs = nixpkgs; system = system; });
- crossTarballOmnia = tarball (self.lib.nixturrisTarballSystem { board = "omnia"; nixpkgs = nixpkgs; system = system; });
+ crossTarballMox = tarball self.nixosConfigurations.mox.config.system.build.cross.${system};
+ crossTarballOmnia = tarball self.nixosConfigurations.omnia.config.system.build.cross.${system};
} // filterPackages system (flattenTree (
import ./pkgs { nixpkgs = nixpkgs.legacyPackages."${system}"; }