aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-04-20 12:11:12 +0200
committerKarel Kočí <cynerd@email.cz>2022-04-20 12:11:12 +0200
commit22b1fcfeb53e0f712315c8008c8be9500832f6f7 (patch)
treecb22853d6106ba916a88aa948263a570a374d68b /flake.nix
parent94f863d84acb5340c3c999f1fa06678f7a5df9f5 (diff)
downloadnixturris-22b1fcfeb53e0f712315c8008c8be9500832f6f7.tar.gz
nixturris-22b1fcfeb53e0f712315c8008c8be9500832f6f7.tar.bz2
nixturris-22b1fcfeb53e0f712315c8008c8be9500832f6f7.zip
flake: allow access to the tarball nixos configuration
This way it is possible to access the nixos config and packages for boards with ease.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix23
1 files changed, 10 insertions, 13 deletions
diff --git a/flake.nix b/flake.nix
index e106ad8..6703267 100644
--- a/flake.nix
+++ b/flake.nix
@@ -16,21 +16,18 @@
lib = import ./lib { self = self; nixpkgs-stable = nixpkgs-stable; };
+ nixosConfigurations = {
+ tarballMox = self.lib.nixturrisTarballSystem { board = "mox"; };
+ tarballOmnia = self.lib.nixturrisTarballSystem { board = "omnia"; };
+ };
+
} // flake-utils.lib.eachSystem (flake-utils.lib.defaultSystems ++ ["armv7l-linux"]) (
system: {
- packages = let
-
- createTarball = {...} @args: (self.lib.nixturrisSystem ({
- modules = [ (import ./tarball.nix args.board) ];
- } // args)).config.system.build.tarball;
-
- in {
-
- tarballMox = createTarball { board = "mox"; };
- tarballOmnia = createTarball { board = "omnia"; };
- crossTarballMox = createTarball { board = "mox"; system = system; };
- crossTarballOmnia = createTarball { board = "omnia"; system = system; };
-
+ packages = {
+ tarballMox = self.nixosConfigurations.tarballMox.config.system.build.tarball;
+ tarballOmnia = self.nixosConfigurations.tarballOmnia.config.system.build.tarball;
+ crossTarballMox = (self.lib.nixturrisTarballSystem { board = "mox"; system = system; }).config.system.build.tarball;
+ crossTarballOmnia = (self.lib.nixturrisTarballSystem { board = "omnia"; system = system; }).config.system.build.tarball;
} // flake-utils.lib.filterPackages system (flake-utils.lib.flattenTree (
import ./pkgs { nixpkgs = nixpkgs-stable.legacyPackages."${system}"; }
));