summaryrefslogtreecommitdiff
path: root/pkgs/turris/crypto-wrapper/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/turris/crypto-wrapper/default.nix')
-rw-r--r--pkgs/turris/crypto-wrapper/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/turris/crypto-wrapper/default.nix b/pkgs/turris/crypto-wrapper/default.nix
new file mode 100644
index 0000000..aa65b17
--- /dev/null
+++ b/pkgs/turris/crypto-wrapper/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, lib, fetchgit
+}:
+
+stdenv.mkDerivation rec {
+ pname = "turris-crypto-wrapper";
+ version = "0.4";
+ meta = with lib; {
+ homepage = "https://gitlab.nic.cz/turris/crypto-wrapper";
+ description = "";
+ license = licenses.gpl3;
+ };
+
+ src = fetchgit {
+ url = "https://gitlab.nic.cz/turris/crypto-wrapper.git";
+ rev = "v" + version;
+ sha256 = "1ly37cajkmgqmlj230h5az9m2m1rgvf4r0bf94yipp80wl0z215s";
+ };
+
+ buildInputs = [czmq msgpack libevent base64c logc-0_1 logc-libs];
+ nativeBuildInputs = [bootstrapHook pkg-config gperf];
+ depsBuildBuild = [check];
+
+ configureFlags = lib.optional (stdenv.hostPlatform == stdenv.buildPlatform) "--enable-tests";
+}