aboutsummaryrefslogtreecommitdiff
path: root/pkgs/stardict/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/stardict/default.nix')
-rw-r--r--pkgs/stardict/default.nix126
1 files changed, 76 insertions, 50 deletions
diff --git a/pkgs/stardict/default.nix b/pkgs/stardict/default.nix
index 9669c3d..cca761a 100644
--- a/pkgs/stardict/default.nix
+++ b/pkgs/stardict/default.nix
@@ -1,55 +1,81 @@
-{ lib, stdenv, fetchurl
-, autoreconfHook, wrapGAppsHook
-, pkg-config, automake, autoconf, libtool, intltool, gnome-doc-utils, libxslt
-, gnome2, gtk2, libxml2, enchant , mariadb-connector-c, pcre
-, speech-tools, speech-toolsDisable ? false
-, espeak, espeakDisable ? false
+{
+ lib,
+ stdenv,
+ fetchurl,
+ autoreconfHook,
+ wrapGAppsHook,
+ pkg-config,
+ automake,
+ autoconf,
+ libtool,
+ intltool,
+ gnome-doc-utils,
+ libxslt,
+ gnome2,
+ gtk2,
+ libxml2,
+ enchant,
+ mariadb-connector-c,
+ pcre,
+ speech-tools,
+ speech-toolsDisable ? false,
+ espeak,
+ espeakDisable ? false,
}:
-
with lib;
+ stdenv.mkDerivation rec {
+ pname = "stardict";
+ version = "3.0.6";
-stdenv.mkDerivation rec {
- pname = "stardict";
- version = "3.0.6";
-
- src = fetchurl {
- url = "https://downloads.sourceforge.net/project/stardict-4/${version}/stardict-${version}.tar.bz2";
- sha256 = "1rw2dg1d489gjjx9957j2jdmjlvylv31pnx3142lwq3pi5d6j2ka";
- };
- patches = [
- ./enchant2.patch
- ./gcc46.patch
- ./gconf.patch
- ./glib2.patch
- ./makefile.patch
- ./mariadb.patch
- ];
+ src = fetchurl {
+ url = "https://downloads.sourceforge.net/project/stardict-4/${version}/stardict-${version}.tar.bz2";
+ sha256 = "1rw2dg1d489gjjx9957j2jdmjlvylv31pnx3142lwq3pi5d6j2ka";
+ };
+ patches = [
+ ./enchant2.patch
+ ./gcc46.patch
+ ./gconf.patch
+ ./glib2.patch
+ ./makefile.patch
+ ./mariadb.patch
+ ];
- nativeBuildInputs = [
- autoreconfHook wrapGAppsHook
- pkg-config intltool gnome-doc-utils libxslt
- ];
- buildInputs = [
- gnome2.gnome-common gnome2.GConf
- gtk2 libxml2 enchant mariadb-connector-c pcre
- ]
- ++ optional (!speech-toolsDisable) speech-tools
- ++ optional (!espeakDisable) espeak;
- configureFlags = [
- "--disable-gnome-support"
- "--disable-gucharmap"
- "--disable-scrollkeeper"
- "--disable-festival"
- "--disable-gpe-support"
- "--disable-schemas-install"
- ]
- ++ optional speech-toolsDisable "--disable-speech-tools"
- ++ optional espeakDisable "--disable-espeak";
+ nativeBuildInputs = [
+ autoreconfHook
+ wrapGAppsHook
+ pkg-config
+ intltool
+ gnome-doc-utils
+ libxslt
+ ];
+ buildInputs =
+ [
+ gnome2.gnome-common
+ gnome2.GConf
+ gtk2
+ libxml2
+ enchant
+ mariadb-connector-c
+ pcre
+ ]
+ ++ optional (!speech-toolsDisable) speech-tools
+ ++ optional (!espeakDisable) espeak;
+ configureFlags =
+ [
+ "--disable-gnome-support"
+ "--disable-gucharmap"
+ "--disable-scrollkeeper"
+ "--disable-festival"
+ "--disable-gpe-support"
+ "--disable-schemas-install"
+ ]
+ ++ optional speech-toolsDisable "--disable-speech-tools"
+ ++ optional espeakDisable "--disable-espeak";
- meta = with lib; {
- description = "Cross-platform and international dictionary software";
- homepage = "http://stardict-4.sourceforge.net/";
- platforms = platforms.linux;
- license = licenses.gpl3;
- };
-}
+ meta = with lib; {
+ description = "Cross-platform and international dictionary software";
+ homepage = "http://stardict-4.sourceforge.net/";
+ platforms = platforms.linux;
+ license = licenses.gpl3;
+ };
+ }