aboutsummaryrefslogtreecommitdiff
path: root/pkgs/shvspy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/shvspy/default.nix')
-rw-r--r--pkgs/shvspy/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/shvspy/default.nix b/pkgs/shvspy/default.nix
new file mode 100644
index 0000000..495a2ec
--- /dev/null
+++ b/pkgs/shvspy/default.nix
@@ -0,0 +1,39 @@
+{ lib, stdenv, fetchFromGitHub
+, cmake, doctest, libsForQt5, qcoro
+, makeDesktopItem, copyDesktopItems
+}:
+with libsForQt5;
+
+stdenv.mkDerivation rec {
+ name = "shvspy";
+
+ src = fetchFromGitHub {
+ owner = "silicon-heaven";
+ repo = "shvspy";
+ rev = "a922e963bf7884164fe2b124a7a4366f7fc802a3";
+ sha256 = "ExA+sFlkxFKXk69DKoGzKm80ypiNFwN281MwZkMgaVY=";
+ fetchSubmodules = true;
+ };
+
+ nativeBuildInputs = [
+ cmake doctest wrapQtAppsHook copyDesktopItems
+ ];
+ buildInputs = [
+ qtbase qtserialport qtwebsockets doctest qcoro
+ ];
+
+ desktopItems = [
+ (makeDesktopItem {
+ name = "shvspy";
+ exec = "shvspy";
+ desktopName = "SHVSpy";
+ categories = [ "Network" "RemoteAccess" ];
+ })
+ ];
+
+ meta = with lib; {
+ description = "Console version of Stardict program";
+ homepage = "https://dushistov.github.io/sdcv/";
+ license = licenses.gpl2;
+ };
+}