aboutsummaryrefslogtreecommitdiff
path: root/pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix31
1 files changed, 1 insertions, 30 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
index 0481720..6c9ba38 100644
--- a/pkgs/default.nix
+++ b/pkgs/default.nix
@@ -29,7 +29,7 @@ pkgs: let
# cyrus_sasl with curus_sasl_xoauth2
cyrus_sasl_xoauth2 = callPackage ./cyrus-sasl-xoauth2 {
- cyrus_sasl = pkgs.cyrus_sasl; # prevent infinite cycle
+ inherit (pkgs) cyrus_sasl;
};
cyrus_sasl = pkgs.cyrus_sasl.overrideAttrs (div: rec {
postInstall = ''
@@ -38,35 +38,6 @@ pkgs: let
done
'';
});
-
- # Nixpkgs fixes
- khal = pkgs.khal.overrideAttrs (oldAttrs: {
- disabledTests =
- pkgs.lib.warnIf (oldAttrs.version != "0.10.5") "Khal is updated. Check if override is still required."
- oldAttrs.disabledTests
- ++ [
- "test__construct_event_format_de_complexer"
- "test__construct_event_format_us"
- "test_alarm"
- "test_berlin"
- "test_berlin_rdate"
- "test_construct_event_format_de"
- "test_construct_event_format_de_complexer"
- "test_construct_event_format_us"
- "test_create_timezone_in_future"
- "test_create_timezone_static"
- "test_description"
- "test_dt_two_tz"
- "test_get"
- "test_leap_year"
- "test_raw_dt"
- "test_repeat_floating"
- "test_repeat_localized"
- "test_split_ics"
- "test_split_ics_random_uid"
- "test_transform_event"
- ];
- });
};
in
personalpkgs