aboutsummaryrefslogtreecommitdiff
path: root/nixos/routers/wifi-spt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/routers/wifi-spt.nix')
-rw-r--r--nixos/routers/wifi-spt.nix82
1 files changed, 41 insertions, 41 deletions
diff --git a/nixos/routers/wifi-spt.nix b/nixos/routers/wifi-spt.nix
index 3d70e18..e726b84 100644
--- a/nixos/routers/wifi-spt.nix
+++ b/nixos/routers/wifi-spt.nix
@@ -30,47 +30,47 @@ in {
config = mkIf cnf.enable {
services.hostapd = {
- countryCode = "CZ";
- environmentFile = "/run/secrets/hostapd.env";
- interfaces =
- (optionalAttrs (cnf.ar9287.interface != null) {
- "${cnf.ar9287.interface}" = hostapd.qualcomAtherosAR9287 {
- inherit (cnf.ar9287) channel;
- bssid = "@BSSID_AR9287_0@";
- ssid = "TurrisRules";
- wpa = 2;
- wpaPassphrase = "@PASS_TURRIS_RULES@";
- bridge = "brlan";
- bss = {
- "${cnf.ar9287.interface}.guest" = {
- bssid = "@BSSID_AR9287_1@";
- ssid = "Kocovi";
- wpa = 2;
- wpaPassphrase = "@PASS_KOCOVI@";
- bridge = "brguest";
- };
- };
- };
- })
- // (optionalAttrs (cnf.qca988x.interface != null) {
- "${cnf.qca988x.interface}" = hostapd.qualcomAtherosQCA988x {
- inherit (cnf.qca988x) channel;
- bssid = "@BSSID_QCA988X_0@";
- ssid = "TurrisRules5";
- wpa = 2;
- wpaPassphrase = "@PASS_TURRIS_RULES@";
- bridge = "brlan";
- bss = {
- "${cnf.qca988x.interface}.guest" = {
- bssid = "@BSSID_QCA988X_1@";
- ssid = "Kocovi";
- wpa = 2;
- wpaPassphrase = "@PASS_KOCOVI@";
- bridge = "brguest";
- };
- };
- };
- });
+ #enable = true;
+ #countryCode = "CZ";
+ #interfaces =
+ # (optionalAttrs (cnf.ar9287.interface != null) {
+ # "${cnf.ar9287.interface}" = hostapd.qualcomAtherosAR9287 {
+ # inherit (cnf.ar9287) channel;
+ # bssid = "@BSSID_AR9287_0@";
+ # ssid = "TurrisRules";
+ # wpa = 2;
+ # wpaPassphrase = "@PASS_TURRIS_RULES@";
+ # bridge = "brlan";
+ # bss = {
+ # "${cnf.ar9287.interface}.guest" = {
+ # bssid = "@BSSID_AR9287_1@";
+ # ssid = "Kocovi";
+ # wpa = 2;
+ # wpaPassphrase = "@PASS_KOCOVI@";
+ # bridge = "brguest";
+ # };
+ # };
+ # };
+ # })
+ # // (optionalAttrs (cnf.qca988x.interface != null) {
+ # "${cnf.qca988x.interface}" = hostapd.qualcomAtherosQCA988x {
+ # inherit (cnf.qca988x) channel;
+ # bssid = "@BSSID_QCA988X_0@";
+ # ssid = "TurrisRules5";
+ # wpa = 2;
+ # wpaPassphrase = "@PASS_TURRIS_RULES@";
+ # bridge = "brlan";
+ # bss = {
+ # "${cnf.qca988x.interface}.guest" = {
+ # bssid = "@BSSID_QCA988X_1@";
+ # ssid = "Kocovi";
+ # wpa = 2;
+ # wpaPassphrase = "@PASS_KOCOVI@";
+ # bridge = "brguest";
+ # };
+ # };
+ # };
+ # });
};
networking.bridges = {
brlan.interfaces = filter (v: v != null) [