aboutsummaryrefslogtreecommitdiff
path: root/nixos/routers/wifi-spt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/routers/wifi-spt.nix')
-rw-r--r--nixos/routers/wifi-spt.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/nixos/routers/wifi-spt.nix b/nixos/routers/wifi-spt.nix
index 39740a1..3d70e18 100644
--- a/nixos/routers/wifi-spt.nix
+++ b/nixos/routers/wifi-spt.nix
@@ -72,5 +72,18 @@ in {
};
});
};
+ networking.bridges = {
+ brlan.interfaces = filter (v: v != null) [
+ cnf.ar9287.interface
+ cnf.qca988x.interface
+ ];
+ brguest.interfaces =
+ (optionals (cnf.ar9287.interface != null) [
+ "${cnf.ar9287.interface}.guest"
+ ])
+ ++ (optionals (cnf.qca988x.interface != null) [
+ "${cnf.qca988x.interface}.guest"
+ ]);
+ };
};
}