aboutsummaryrefslogtreecommitdiff
path: root/nixos/routers/wifi-spt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/routers/wifi-spt.nix')
-rw-r--r--nixos/routers/wifi-spt.nix13
1 files changed, 4 insertions, 9 deletions
diff --git a/nixos/routers/wifi-spt.nix b/nixos/routers/wifi-spt.nix
index 1cbb567..a7b2697 100644
--- a/nixos/routers/wifi-spt.nix
+++ b/nixos/routers/wifi-spt.nix
@@ -29,16 +29,14 @@ in {
};
config = mkIf cnf.enable {
- networking.wirelessAP = {
- enable = true;
+ services.hostapd = {
+ countryCode = "CZ";
environmentFile = "/run/secrets/hostapd.env";
interfaces =
(optionalAttrs (cnf.ar9287.interface != null) {
"${cnf.ar9287.interface}" =
- wifiAP.qualcomAtherosAR9287 {
+ hostapd.qualcomAtherosAR9287 {
channel = cnf.ar9287.channel;
- }
- // {
bssid = "@BSSID_AR9287_0@";
ssid = "TurrisRules";
wpa = 2;
@@ -57,12 +55,9 @@ in {
})
// (optionalAttrs (cnf.qca988x.interface != null) {
"${cnf.qca988x.interface}" =
- wifiAP.qualcomAtherosQCA988x {
+ hostapd.qualcomAtherosQCA988x {
channel = cnf.qca988x.channel;
- }
- // {
bssid = "@BSSID_QCA988X_0@";
- countryCode = "CZ";
ssid = "TurrisRules5";
wpa = 2;
wpaPassphrase = "@PASS_TURRIS_RULES@";