aboutsummaryrefslogtreecommitdiff
path: root/nixos/routers/wifi-spt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/routers/wifi-spt.nix')
-rw-r--r--nixos/routers/wifi-spt.nix112
1 files changed, 56 insertions, 56 deletions
diff --git a/nixos/routers/wifi-spt.nix b/nixos/routers/wifi-spt.nix
index 84527fd..0ebcaa1 100644
--- a/nixos/routers/wifi-spt.nix
+++ b/nixos/routers/wifi-spt.nix
@@ -54,14 +54,14 @@ in {
wpaPasswordFile = "/run/secrets/hostapd-TurrisRules.pass";
};
};
- "${cnf.ar9287.interface}.guest" = {
- bssid = elemAt cnf.ar9287.bssids 1;
- ssid = "Kocovi";
- authentication = {
- mode = "wpa2-sha256";
- wpaPasswordFile = "/run/secrets/hostapd-Kocovi.pass";
- };
- };
+ #"${cnf.ar9287.interface}.guest" = {
+ # bssid = elemAt cnf.ar9287.bssids 1;
+ # ssid = "Kocovi";
+ # authentication = {
+ # mode = "wpa2-sha256";
+ # wpaPasswordFile = "/run/secrets/hostapd-Kocovi.pass";
+ # };
+ #};
};
};
}
@@ -96,14 +96,14 @@ in {
wpaPasswordFile = "/run/secrets/hostapd-TurrisRules.pass";
};
};
- "${cnf.qca988x.interface}.guest" = {
- bssid = elemAt cnf.qca988x.bssids 1;
- ssid = "Kocovi";
- authentication = {
- mode = "wpa2-sha256";
- wpaPasswordFile = "/run/secrets/hostapd-Kocovi.pass";
- };
- };
+ #"${cnf.qca988x.interface}.guest" = {
+ # bssid = elemAt cnf.qca988x.bssids 1;
+ # ssid = "Kocovi";
+ # authentication = {
+ # mode = "wpa2-sha256";
+ # wpaPasswordFile = "/run/secrets/hostapd-Kocovi.pass";
+ # };
+ #};
};
};
};
@@ -113,53 +113,53 @@ in {
"lan-${cnf.ar9287.interface}" = {
matchConfig.Name = cnf.ar9287.interface;
networkConfig.Bridge = "brlan";
- bridgeVLANs = [
- {
- bridgeVLANConfig = {
- EgressUntagged = 1;
- PVID = 1;
- };
- }
- ];
- };
- "lan-${cnf.ar9287.interface}-guest" = {
- matchConfig.Name = "${cnf.ar9287.interface}.guest";
- networkConfig.Bridge = "brlan";
- bridgeVLANs = [
- {
- bridgeVLANConfig = {
- EgressUntagged = 2;
- PVID = 2;
- };
- }
- ];
+ #bridgeVLANs = [
+ # {
+ # bridgeVLANConfig = {
+ # EgressUntagged = 1;
+ # PVID = 1;
+ # };
+ # }
+ #];
};
+ #"lan-${cnf.ar9287.interface}-guest" = {
+ # matchConfig.Name = "${cnf.ar9287.interface}.guest";
+ # networkConfig.Bridge = "brlan";
+ # bridgeVLANs = [
+ # {
+ # bridgeVLANConfig = {
+ # EgressUntagged = 2;
+ # PVID = 2;
+ # };
+ # }
+ # ];
+ #};
}
// mkIf (cnf.qca988x.interface != null) {
"lan-${cnf.qca988x.interface}" = {
matchConfig.Name = cnf.qca988x.interface;
networkConfig.Bridge = "brlan";
- bridgeVLANs = [
- {
- bridgeVLANConfig = {
- EgressUntagged = 1;
- PVID = 1;
- };
- }
- ];
- };
- "lan-${cnf.qca988x.interface}-guest" = {
- matchConfig.Name = "${cnf.qca988x.interface}.guest";
- networkConfig.Bridge = "brlan";
- bridgeVLANs = [
- {
- bridgeVLANConfig = {
- EgressUntagged = 2;
- PVID = 2;
- };
- }
- ];
+ #bridgeVLANs = [
+ # {
+ # bridgeVLANConfig = {
+ # EgressUntagged = 1;
+ # PVID = 1;
+ # };
+ # }
+ #];
};
+ #"lan-${cnf.qca988x.interface}-guest" = {
+ # matchConfig.Name = "${cnf.qca988x.interface}.guest";
+ # networkConfig.Bridge = "brlan";
+ # bridgeVLANs = [
+ # {
+ # bridgeVLANConfig = {
+ # EgressUntagged = 2;
+ # PVID = 2;
+ # };
+ # }
+ # ];
+ #};
};
};
}