aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/wireguad.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/wireguad.nix')
-rw-r--r--nixos/modules/wireguad.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/nixos/modules/wireguad.nix b/nixos/modules/wireguad.nix
new file mode 100644
index 0000000..67bd8d5
--- /dev/null
+++ b/nixos/modules/wireguad.nix
@@ -0,0 +1,18 @@
+{
+ config,
+ lib,
+ ...
+}: let
+ inherit (lib) mkEnableOption mkIf;
+ cnf = config.cynerd.wireguard;
+in {
+ options = {
+ cynerd.wireguard = {
+ enable = mkEnableOption "Enable Wireguard";
+ };
+ };
+
+ config =
+ mkIf cnf.enable {
+ };
+}