aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/wifi-spt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/wifi-spt.nix')
-rw-r--r--nixos/modules/wifi-spt.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/nixos/modules/wifi-spt.nix b/nixos/modules/wifi-spt.nix
index 11554a7..669439d 100644
--- a/nixos/modules/wifi-spt.nix
+++ b/nixos/modules/wifi-spt.nix
@@ -102,7 +102,7 @@ in {
mode = "wpa2-sha256";
wpaPasswordFile = "/run/secrets/hostapd-TurrisRules.pass";
};
- settings = {
+ settings = mkIf is2g {
ieee80211w = 0;
wpa_key_mgmt = mkForce "WPA-PSK"; # force use without sha256
};
@@ -123,7 +123,10 @@ in {
systemd.network.networks = mkMerge [
(mkIf (cnf.ar9287.interface != null) {
"lan-${cnf.ar9287.interface}" = {
- matchConfig.Name = cnf.ar9287.interface;
+ matchConfig = {
+ Name = cnf.ar9287.interface;
+ WLANInterfaceType = "ap";
+ };
networkConfig.Bridge = "brlan";
bridgeVLANs = [
{
@@ -149,7 +152,10 @@ in {
})
(mkIf (cnf.qca988x.interface != null) {
"lan-${cnf.qca988x.interface}" = {
- matchConfig.Name = cnf.qca988x.interface;
+ matchConfig = {
+ Name = cnf.qca988x.interface;
+ WLANInterfaceType = "ap";
+ };
networkConfig.Bridge = "brlan";
bridgeVLANs = [
{