aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/wifi-client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/wifi-client.nix')
-rw-r--r--nixos/modules/wifi-client.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/wifi-client.nix b/nixos/modules/wifi-client.nix
index 0d7fd48..8fc803d 100644
--- a/nixos/modules/wifi-client.nix
+++ b/nixos/modules/wifi-client.nix
@@ -3,8 +3,9 @@
lib,
pkgs,
...
-}:
-with lib; {
+}: let
+ inherit (lib) mkOption types mkIf;
+in {
options = {
cynerd.wifiClient = mkOption {
type = types.bool;