aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/wifi-client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/wifi-client.nix')
-rw-r--r--nixos/modules/wifi-client.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/nixos/modules/wifi-client.nix b/nixos/modules/wifi-client.nix
new file mode 100644
index 0000000..af09155
--- /dev/null
+++ b/nixos/modules/wifi-client.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ options = {
+ cynerd.wifiClient = mkOption {
+ type = types.bool;
+ default = false;
+ description = "Enable Wi-Fi client support";
+ };
+ };
+
+ config = mkIf config.cynerd.wifiClient {
+ networking.wireless = {
+ enable = true;
+ networks = config.secrets.wifiNetworks;
+ environmentFile = "/run/secrets/wifi.env";
+ userControlled.enable = true;
+ };
+ };
+}