aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/syncthing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/syncthing.nix')
-rw-r--r--nixos/modules/syncthing.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/syncthing.nix b/nixos/modules/syncthing.nix
index 716e5a3..263acbe 100644
--- a/nixos/modules/syncthing.nix
+++ b/nixos/modules/syncthing.nix
@@ -7,7 +7,7 @@
with builtins;
with lib; let
cnf = config.cynerd.syncthing;
- hostName = config.networking.hostName;
+ inherit (config.networking) hostName;
allDevices = [
"albert"
"binky"
@@ -29,7 +29,7 @@ with lib; let
"ridcully"
"spt-omnia"
];
- filterDevice = folders: filterAttrs (n: v: any (d: d == hostName) v.devices) folders;
+ filterDevice = filterAttrs (n: v: any (d: d == hostName) v.devices);
in {
options = {
cynerd.syncthing = {