aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/syncthing.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-02-06 20:44:14 +0100
committerKarel Kočí <cynerd@email.cz>2023-02-06 20:44:14 +0100
commit8b96dd41971e008a6a2527fe10c6670d2248117e (patch)
treec7327ec26648e62279778696e38dc70415d16151 /nixos/modules/syncthing.nix
parentadc6902502aa03509d138e9220843bf4d6a1a390 (diff)
downloadnixos-personal-8b96dd41971e008a6a2527fe10c6670d2248117e.tar.gz
nixos-personal-8b96dd41971e008a6a2527fe10c6670d2248117e.tar.bz2
nixos-personal-8b96dd41971e008a6a2527fe10c6670d2248117e.zip
Apply statix suggestions
Diffstat (limited to 'nixos/modules/syncthing.nix')
-rw-r--r--nixos/modules/syncthing.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/syncthing.nix b/nixos/modules/syncthing.nix
index 716e5a3..263acbe 100644
--- a/nixos/modules/syncthing.nix
+++ b/nixos/modules/syncthing.nix
@@ -7,7 +7,7 @@
with builtins;
with lib; let
cnf = config.cynerd.syncthing;
- hostName = config.networking.hostName;
+ inherit (config.networking) hostName;
allDevices = [
"albert"
"binky"
@@ -29,7 +29,7 @@ with lib; let
"ridcully"
"spt-omnia"
];
- filterDevice = folders: filterAttrs (n: v: any (d: d == hostName) v.devices) folders;
+ filterDevice = filterAttrs (n: v: any (d: d == hostName) v.devices);
in {
options = {
cynerd.syncthing = {