aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/home-assistant.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/home-assistant.nix')
-rw-r--r--nixos/modules/home-assistant.nix70
1 files changed, 0 insertions, 70 deletions
diff --git a/nixos/modules/home-assistant.nix b/nixos/modules/home-assistant.nix
index e9d6338..bf98609 100644
--- a/nixos/modules/home-assistant.nix
+++ b/nixos/modules/home-assistant.nix
@@ -53,76 +53,6 @@ in {
password = "@PASS_MQTT@";
};
};
- mqtt2influxdb = {
- # TODO remove as we have telegraf
- enable = true;
- environmentFile = "/run/secrets/bigclown.env";
- mqtt = {
- username = "bigclown";
- password = "@PASS_MQTT@";
- };
- influxdb = {
- host = "cynerd.cz";
- database = "bigclown";
- username = "bigclown";
- password = "@PASS_INFLUXDB@";
- ssl = true;
- verify_ssl = false;
- };
- points = [
- {
- measurement = "temperature";
- topic = "bigclown/node/+/thermometer/+/temperature";
- fields.value = "$.payload";
- tags = {
- id = "$.topic[2]";
- channel = "$.topic[4]";
- };
- }
- {
- measurement = "relative-humidity";
- topic = "bigclown/node/+/hygrometer/+/relative-humidity";
- fields.value = "$.payload";
- tags = {
- id = "$.topic[2]";
- channel = "$.topic[4]";
- };
- }
- {
- measurement = "illuminance";
- topic = "bigclown/node/+/lux-meter/0:0/illuminance";
- fields.value = "$.payload";
- tags = {
- id = "$.topic[2]";
- };
- }
- {
- measurement = "pressure";
- topic = "bigclown/node/+/barometer/0:0/pressure";
- fields.value = "$.payload";
- tags = {
- id = "$.topic[2]";
- };
- }
- {
- measurement = "voltage";
- topic = "bigclown/node/+/battery/+/voltage";
- fields.value = "$.payload";
- tags = {
- id = "$.topic[2]";
- };
- }
- {
- measurement = "button";
- topic = "bigclown/node/+/push-button/+/event-count";
- fields.value = "$.payload";
- tags = {
- id = "$.topic[2]";
- channel = "$.topic[4]";
- };
- }
- ];
- };
};
systemd.services.bigclown-leds = {