aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/generic.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/generic.nix')
-rw-r--r--nixos/modules/generic.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/nixos/modules/generic.nix b/nixos/modules/generic.nix
index ff635cf..fb2879c 100644
--- a/nixos/modules/generic.nix
+++ b/nixos/modules/generic.nix
@@ -131,6 +131,11 @@ in {
'';
})
];
+
+ system.extraSystemBuilderCmds = ''
+ substituteAll ${./nixos-system.sh} $out/bin/nixos-system
+ chmod +x $out/bin/nixos-system
+ '';
};
}