aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/generic.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/generic.nix')
-rw-r--r--nixos/modules/generic.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/generic.nix b/nixos/modules/generic.nix
index 31f0829..546e04a 100644
--- a/nixos/modules/generic.nix
+++ b/nixos/modules/generic.nix
@@ -31,6 +31,7 @@ with lib;
# Administration tools
coreutils moreutils psmisc progress lshw
dig
+ gnumake
# NCurses tools
htop iotop glances
@@ -67,14 +68,14 @@ with lib;
passwordFile = "/run/secrets/root.pass";
};
cynerd = {
+ group = "cynerd";
+ extraGroups = ["users" "wheel"];
uid = 1000;
subUidRanges = [{ count = 65534; startUid = 10000; }];
subGidRanges = [{ count = 65534; startGid = 10000; }];
- group = "cynerd";
isNormalUser = true;
createHome = true;
shell = pkgs.zsh.out;
- extraGroups = ["users" "wheel"];
passwordFile = "/run/secrets/cynerd.pass";
openssh.authorizedKeys.keyFiles = [
(config.personal-secrets + "/unencrypted/git-private.pub")