aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/generic.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/generic.nix')
-rw-r--r--nixos/modules/generic.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/nixos/modules/generic.nix b/nixos/modules/generic.nix
index 309dd95..02498a3 100644
--- a/nixos/modules/generic.nix
+++ b/nixos/modules/generic.nix
@@ -5,7 +5,7 @@
...
}:
with lib; let
- isNative = config.nixpkgs.crossSystem == null;
+ isNative = config.nixpkgs.hostPlatform == config.nixpkgs.buildPlatform;
in {
config = {
system.stateVersion = "22.05";
@@ -89,6 +89,7 @@ in {
nethogs
sshfs
wakeonlan
+ speedtest-cli
lm_sensors
]
@@ -139,8 +140,11 @@ in {
];
};
};
- programs.zsh.enable = isNative;
- programs.shellrc.enable = true;
+ programs.zsh = {
+ enable = isNative;
+ syntaxHighlighting.enable = isNative;
+ };
+ programs.shellrc = true;
programs.vim.defaultEditor = mkDefault true;
security.sudo.extraRules = [