aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/develop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/develop.nix')
-rw-r--r--nixos/modules/develop.nix27
1 files changed, 23 insertions, 4 deletions
diff --git a/nixos/modules/develop.nix b/nixos/modules/develop.nix
index 3ef6ce6..cc8ce76 100644
--- a/nixos/modules/develop.nix
+++ b/nixos/modules/develop.nix
@@ -30,15 +30,19 @@ in {
tio
vim-vint
nodePackages.vim-language-server
- ctags
+ vale
+
+ # Required for neovim plugins
+ editorconfig-checker
+ go
+ gcc
# Nix
dev
cachix
nurl
nix-universal-prefetch
- rnix-lsp
- nixd
+ nil
alejandra
statix
deadnix
@@ -49,10 +53,14 @@ in {
bats
shellcheck
shfmt
+ nodePackages.bash-language-server
jq
yq
fq
+ # C
+ clang-tools
+
# Python
(python3.withPackages (pypkgs:
with pypkgs; [
@@ -73,9 +81,14 @@ in {
python-gitlab
PyGithub
]))
+ ruff
geckodriver
chromedriver
+ # Lua
+ selene
+ stylua
+
# Julia
julia
@@ -99,7 +112,7 @@ in {
barcode
# D-Bus
- dfeet
+ d-spy
# Documentation
man-pages
@@ -152,5 +165,11 @@ in {
"develop"
"libvirtd"
];
+
+ # Allow using latest git version from registry
+ nixpkgs.flake = {
+ setNixPath = false;
+ setFlakeRegistry = false;
+ };
};
}