aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/develop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/develop.nix')
-rw-r--r--nixos/modules/develop.nix27
1 files changed, 24 insertions, 3 deletions
diff --git a/nixos/modules/develop.nix b/nixos/modules/develop.nix
index 5e812b2..2daead8 100644
--- a/nixos/modules/develop.nix
+++ b/nixos/modules/develop.nix
@@ -70,9 +70,6 @@ in {
pytest-html
pytest-tap
coverage
- python-lsp-black
- pylint
- pydocstyle
mypy
pygraphviz
@@ -80,10 +77,34 @@ in {
python-gitlab
PyGithub
+
+ schema
+ jinja2
+ ruamel-yaml
+ msgpack
+ urllib3
+
+ influxdb-client
+ psycopg
+ paho-mqtt
+
+ humanize
+ rich
+
+ pygobject3
+
+ pyserial
+ pylibftdi
+ pylxd
+ selenium
]))
ruff
geckodriver
chromedriver
+ # Libraries to be used by python packages
+ gobject-introspection
+ gtk3
+ gtk4
# Lua
selene