aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/desktop.nix')
-rw-r--r--nixos/modules/desktop.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/nixos/modules/desktop.nix b/nixos/modules/desktop.nix
index 87dc12e..e33a8d9 100644
--- a/nixos/modules/desktop.nix
+++ b/nixos/modules/desktop.nix
@@ -66,7 +66,7 @@ in {
#khal
#khard
gnupg
- pinentry-gnome
+ pinentry-gnome3
pinentry-curses
(pass.withExtensions (exts: [
exts.pass-otp
@@ -166,7 +166,6 @@ in {
acpi
]);
};
- vim.package = pkgs.vimHugeX;
firefox = {
enable = true;
languagePacks = ["en-US" "cs"];
@@ -210,12 +209,10 @@ in {
alsa.enable = true;
alsa.support32Bit = true;
pulse.enable = true;
+ extraConfig.pipewire."10-zeroconf" = {
+ "context.modules" = [{name = "libpipewire-module-zeroconf-discover";}];
+ };
};
- environment.etc."pipewire/pipewire.conf.d/zeroconf.conf".text = ''
- context.modules = [
- { name = libpipewire-module-zeroconf-discover }
- ]
- '';
security.rtkit.enable = true;
services.printing = {
@@ -236,6 +233,7 @@ in {
networking.firewall.allowedUDPPorts = [3702];
fonts.packages = with pkgs; [
+ nerdfonts
arkpandora_ttf
corefonts
dejavu_fonts
@@ -324,6 +322,8 @@ in {
services.locate.enable = true;
+ services.davfs2.enable = true;
+
# Support running app images
boot.binfmt.registrations.appimage = {
wrapInterpreterInShell = false;