aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/desktop.nix')
-rw-r--r--nixos/modules/desktop.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/nixos/modules/desktop.nix b/nixos/modules/desktop.nix
index f59ea09..fd79073 100644
--- a/nixos/modules/desktop.nix
+++ b/nixos/modules/desktop.nix
@@ -33,9 +33,6 @@ in {
config = mkIf cnf.enable {
cynerd.hosts.enable = true;
- # TODO autologin but only on tty1
- services.gpm.enable = true;
-
programs.sway.enable = true;
programs.sway.wrapperFeatures.gtk = true;
programs.sway.extraPackages = with pkgs; [
@@ -206,6 +203,7 @@ in {
};
};
+ # Autologin on the first TTY
services.getty = {
extraArgs = [ "--skip-login" ];
loginProgram = "${pkgs.bash}/bin/sh";
@@ -218,5 +216,17 @@ in {
'');
};
+ # VTI settings
+ console = {
+ colors = [
+ "2e3440" "3b4252" "434c5e" "4c566a" "d8dee9" "e5e9f0" "eceff4" "8fbcbb"
+ "88c0d0" "81a1c1" "5e81ac" "bf616a" "d08770" "ebcb8b" "a3be8c" "b48ead"
+ ];
+ earlySetup = true;
+ useXkbConfig = true;
+ };
+ services.xserver.xkbOptions = "grp:alt_shift_toggle,caps:escape";
+ services.gpm.enable = true;
+
};
}