aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/desktop.nix')
-rw-r--r--nixos/modules/desktop.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/nixos/modules/desktop.nix b/nixos/modules/desktop.nix
index 6979252..87dc12e 100644
--- a/nixos/modules/desktop.nix
+++ b/nixos/modules/desktop.nix
@@ -193,7 +193,7 @@ in {
programs.usbkey = {
enable = true;
- devicesUUID = [];
+ devicesUUID = ["de269652-2070-46b2-84f8-409dc9dd50ee" "16a089d0-a663-4047-bd88-3885dd7fdee2"];
};
programs.gnupg.agent = {
@@ -254,8 +254,10 @@ in {
services.udev.extraRules = ''
ACTION=="add|change", KERNEL=="sd*[!0-9]", ATTR{queue/scheduler}="bfq"
'';
- hardware.opengl.driSupport = true;
- hardware.opengl.driSupport32Bit = true;
+ hardware.opengl = {
+ driSupport = true;
+ driSupport32Bit = true;
+ };
hardware.bluetooth.enable = mkIf cnf.laptop true;