aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/desktop.nix')
-rw-r--r--nixos/modules/desktop.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nixos/modules/desktop.nix b/nixos/modules/desktop.nix
index c4a2b5b..38758c7 100644
--- a/nixos/modules/desktop.nix
+++ b/nixos/modules/desktop.nix
@@ -314,5 +314,15 @@ in {
services.gpm.enable = true;
services.locate.enable = true;
+
+ # Support running app images
+ boot.binfmt.registrations.appimage = {
+ wrapInterpreterInShell = false;
+ interpreter = "${pkgs.appimage-run}/bin/appimage-run";
+ recognitionType = "magic";
+ offset = 0;
+ mask = ''\xff\xff\xff\xff\x00\x00\x00\x00\xff\xff\xff'';
+ magicOrExtension = ''\x7fELF....AI\x02'';
+ };
};
}