aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/default.nix')
-rw-r--r--nixos/modules/default.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/nixos/modules/default.nix b/nixos/modules/default.nix
index 7afdc95..ea2acb3 100644
--- a/nixos/modules/default.nix
+++ b/nixos/modules/default.nix
@@ -1,9 +1,10 @@
-self: let
+{lib}: let
inherit (builtins) readDir;
- inherit (self.inputs.nixpkgs.lib) filterAttrs nameValuePair mapAttrs' hasSuffix removeSuffix;
+ inherit (lib) filterAttrs hasSuffix mapAttrs' nameValuePair removeSuffix;
in
mapAttrs'
- (n: v: nameValuePair "cynerd-${removeSuffix ".nix" n}" (./. + "/${n}"))
- (filterAttrs
- (n: v: v == "regular" && hasSuffix ".nix" n && n != "default.nix")
- (readDir ./.))
+ (fname: _: nameValuePair (removeSuffix ".nix" fname) (./. + ("/" + fname)))
+ (filterAttrs (
+ n: v:
+ v == "regular" && n != "default.nix" && hasSuffix ".nix" n
+ ) (readDir ./.))