aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/susan.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/susan.nix')
-rw-r--r--nixos/machine/susan.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/nixos/machine/susan.nix b/nixos/machine/susan.nix
new file mode 100644
index 0000000..b452ed9
--- /dev/null
+++ b/nixos/machine/susan.nix
@@ -0,0 +1,26 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = {
+ cynerd.desktop.enable = true;
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/e092a3ad-fb32-44fa-bc1f-14c2733da033";
+ options = ["compress=lzo" "subvol=@nix"];
+ };
+ "/home" = {
+ device = "/dev/disk/by-uuid/e092a3ad-fb32-44fa-bc1f-14c2733da033";
+ options = ["compress=lzo" "subvol=@home"];
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/EB3E-3635";
+ };
+ };
+
+ };
+
+}