aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/spt-omnia.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/spt-omnia.nix')
-rw-r--r--nixos/machine/spt-omnia.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nixos/machine/spt-omnia.nix b/nixos/machine/spt-omnia.nix
index 21bfeb6..4cb80c4 100644
--- a/nixos/machine/spt-omnia.nix
+++ b/nixos/machine/spt-omnia.nix
@@ -5,6 +5,23 @@ with lib;
{
config = {
+ cynerd = {
+ openvpn.oldpersonal = true;
+ };
+
+ services.syncthing = {
+ enable = true;
+ #user = mkDefault "cynerd";
+ #group = mkDefault "cynerd";
+ openDefaultPorts = true;
+
+ overrideDevices = false;
+ overrideFolders = false;
+
+ dataDir = "/data";
+ configDir = "/srv/syncthing";
+ };
+
};
}