aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/spt-omnia.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/spt-omnia.nix')
-rw-r--r--nixos/machine/spt-omnia.nix40
1 files changed, 22 insertions, 18 deletions
diff --git a/nixos/machine/spt-omnia.nix b/nixos/machine/spt-omnia.nix
index 15cabb6..c0a6ec2 100644
--- a/nixos/machine/spt-omnia.nix
+++ b/nixos/machine/spt-omnia.nix
@@ -47,31 +47,35 @@ with lib; {
};
"end2.848" = {
matchConfig.Name = "end2.848";
+ networkConfig.BindCarrier = "end2";
+ };
+ "pppoe-wan" = {
+ matchConfig.Name = "pppoe-wan";
networkConfig = {
- BindCarrier = "end2";
- #DHCP = "ipv6";
- #IPv6AcceptRA = "yes";
- #DHCPPrefixDelegation = "yes";
+ BindCarrier = "end2.848";
+ DHCP = "ipv6";
+ IPv6AcceptRA = "yes";
+ DHCPPrefixDelegation = "yes";
+ };
+ dhcpPrefixDelegationConfig = {
+ UplinkInterface = ":self";
+ SubnetId = 0;
+ Announce = "no";
};
- #dhcpPrefixDelegationConfig = {
- # UplinkInterface = ":self";
- # SubnetId = 0;
- # Announce = "no";
- #};
linkConfig.RequiredForOnline = "routable";
};
"lan-brlan" = {
matchConfig.Name = "lan*";
networkConfig.Bridge = "brlan";
- bridgeVLANs = [
- {
- bridgeVLANConfig = {
- EgressUntagged = 1;
- PVID = 1;
- };
- }
- {bridgeVLANConfig.VLAN = 2;}
- ];
+ #bridgeVLANs = [
+ # {
+ # bridgeVLANConfig = {
+ # EgressUntagged = 1;
+ # PVID = 1;
+ # };
+ # }
+ # {bridgeVLANConfig.VLAN = 2;}
+ #];
};
};
};