aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/spt-mox2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/spt-mox2.nix')
-rw-r--r--nixos/machine/spt-mox2.nix88
1 files changed, 42 insertions, 46 deletions
diff --git a/nixos/machine/spt-mox2.nix b/nixos/machine/spt-mox2.nix
index 73aba50..45035d4 100644
--- a/nixos/machine/spt-mox2.nix
+++ b/nixos/machine/spt-mox2.nix
@@ -1,55 +1,51 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib; {
- config = {
- deploy = {
+{config, ...}: {
+ deploy = {
+ enable = true;
+ ssh.host = "mox2.spt";
+ };
+
+ cynerd = {
+ switch = {
enable = true;
- ssh.host = "mox2.spt";
+ lanAddress = "${config.cynerd.hosts.spt.mox2}/24";
+ lanGateway = config.cynerd.hosts.spt.omnia;
};
-
- cynerd = {
- switch = {
- enable = true;
- lanAddress = "${config.cynerd.hosts.spt.mox2}/24";
- lanGateway = config.cynerd.hosts.spt.omnia;
- };
- wifiAP.spt = {
- enable = true;
- qca988x = {
- interface = "wls1";
- bssids = ["04:f0:21:45:d3:47" "08:f0:21:45:d3:47"];
- channel = 1;
- };
+ wifiAP.spt = {
+ enable = true;
+ qca988x = {
+ interface = "wls1";
+ bssids = ["04:f0:21:45:d3:47" "08:f0:21:45:d3:47"];
+ channel = 1;
};
};
+ };
- services.btrfs.autoScrub = {
- enable = true;
- fileSystems = ["/"];
- };
+ services.journald.extraConfig = ''
+ SystemMaxUse=512M
+ '';
- networking = {
- useNetworkd = true;
- useDHCP = false;
- };
- systemd.network.networks = {
- "lan-brlan" = {
- matchConfig.Name = "end0";
- networkConfig.Bridge = "brlan";
- bridgeVLANs = [
- {
- bridgeVLANConfig = {
- EgressUntagged = 1;
- PVID = 1;
- };
- }
- {bridgeVLANConfig.VLAN = 2;}
- ];
- };
+ services.btrfs.autoScrub = {
+ enable = true;
+ fileSystems = ["/"];
+ };
+
+ networking = {
+ useNetworkd = true;
+ useDHCP = false;
+ };
+ systemd.network.networks = {
+ "lan-brlan" = {
+ matchConfig.Name = "end0";
+ networkConfig.Bridge = "brlan";
+ bridgeVLANs = [
+ {
+ bridgeVLANConfig = {
+ EgressUntagged = 1;
+ PVID = 1;
+ };
+ }
+ {bridgeVLANConfig.VLAN = 2;}
+ ];
};
};
}