aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/spt-mox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/spt-mox.nix')
-rw-r--r--nixos/machine/spt-mox.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nixos/machine/spt-mox.nix b/nixos/machine/spt-mox.nix
new file mode 100644
index 0000000..eb304b2
--- /dev/null
+++ b/nixos/machine/spt-mox.nix
@@ -0,0 +1,31 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = {
+ networking = {
+ vlans = {
+ "eth0.2" = {
+ id = 2;
+ interface = "eth0";
+ };
+ };
+ bridges = {
+ brlan = {
+ interfaces = [
+ "eth0" "lan1" "lan2" "lan3" "lan4"
+ ];
+ };
+ brguest = {
+ interfaces = [
+ "eth0.2"
+ ];
+ };
+ };
+ dhcpcd.allowInterfaces = [ "brlan" ];
+ };
+ };
+
+}