aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/spt-mox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/spt-mox.nix')
-rw-r--r--nixos/machine/spt-mox.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nixos/machine/spt-mox.nix b/nixos/machine/spt-mox.nix
index eb304b2..bb0ac5e 100644
--- a/nixos/machine/spt-mox.nix
+++ b/nixos/machine/spt-mox.nix
@@ -24,6 +24,16 @@ with lib;
];
};
};
+ interfaces.brlan = {
+ ipv4 = {
+ addresses = [{
+ address = config.cynerd.hosts.spt.mox;
+ prefixLength = 24;
+ }];
+ };
+ };
+ defaultGateway = config.cynerd.hosts.spt.omnia;
+ nameservers = [ config.cynerd.hosts.spt.omnia "1.1.1.1" "8.8.8.8" ];
dhcpcd.allowInterfaces = [ "brlan" ];
};
};