aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/spt-mox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/spt-mox.nix')
-rw-r--r--nixos/machine/spt-mox.nix29
1 files changed, 9 insertions, 20 deletions
diff --git a/nixos/machine/spt-mox.nix b/nixos/machine/spt-mox.nix
index 5af8bff..037b10e 100644
--- a/nixos/machine/spt-mox.nix
+++ b/nixos/machine/spt-mox.nix
@@ -1,5 +1,6 @@
{ config, lib, pkgs, ... }:
+with builtins;
with lib;
{
@@ -10,30 +11,18 @@ with lib;
enable = true;
environmentFile = "/run/secrets/hostapd.env";
interfaces = {
- #"mlan0" = {
- #countryCode = "CZ";
- #ssid = "TurrisRules";
- #wpa = true;
- #wpaPassphrase = "@PASS_TURRIS_RULES@";
- #};
- "wlp1s0" = {
+ "wlp4s0" = {
countryCode = "CZ";
- hwMode = "a";
- channel = 40;
- ieee80211ac = true;
- ht_capab = ["HT40+" "LDPC" "SHORT-GI-20" "SHORT-GI-40" "TX-STBC" "RX-STBC1" "MAX-AMSDU-7935" "DSSS_CCK-40"];
- vht_capab = ["RXLDPC" "SHORT-GI-80" "TX-STBC-2BY1" "RX-ANTENNA-PATTERN" "TX-ANTENNA-PATTERN" "RX-STBC-1" "MAX-MPDU-11454" "MAX-A-MPDU-LEN-EXP7"];
- ssid = "TurrisRules5";
+ channel = 7;
+ hwMode = "g";
+ ht_capab = ["HT40+" "SHORT-GI-20" "SHORT-GI-40" "TX-STBC" "RX-STBC1" "DSSS_CCK-40"];
+ ssid = "TurrisRules";
+ bridge = "brlan";
wpa = true;
+ wpa3 = false;
wpaPassphrase = "@PASS_TURRIS_RULES@";
- bss = {
- "wlp1s0host" = {
- ssid = "KocoviGuest";
- wpa = true;
- wpaPassphrase = "@PASS_KOCOVI@";
- };
- };
};
+ # TODO use use wlp3s0 with 80211ax
};
};