aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/ridcully.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/ridcully.nix')
-rw-r--r--nixos/machine/ridcully.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nixos/machine/ridcully.nix b/nixos/machine/ridcully.nix
new file mode 100644
index 0000000..882f967
--- /dev/null
+++ b/nixos/machine/ridcully.nix
@@ -0,0 +1,31 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = {
+ cynerd.desktop.enable = true;
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/3b3063aa-c284-4075-bb37-8820df12a2f5";
+ options = ["compress=lzo" "subvol=@nix"];
+ };
+ "/home" = {
+ device = "/dev/disk/by-uuid/3b3063aa-c284-4075-bb37-8820df12a2f5";
+ options = ["compress=lzo" "subvol=@home"];
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/C1A0-B7C9";
+ };
+
+ "/home2" = {
+ device = "/dev/disk/by-uuid/c9aa0b7b-7482-4d4a-bcc3-8bd6a853ae7f";
+ options = ["compress=lzo" "subvol=@home"];
+ };
+ };
+
+ };
+
+}