aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/ridcully.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/ridcully.nix')
-rw-r--r--nixos/machine/ridcully.nix34
1 files changed, 30 insertions, 4 deletions
diff --git a/nixos/machine/ridcully.nix b/nixos/machine/ridcully.nix
index 882f967..4c0bba9 100644
--- a/nixos/machine/ridcully.nix
+++ b/nixos/machine/ridcully.nix
@@ -5,15 +5,28 @@ with lib;
{
config = {
- cynerd.desktop.enable = true;
+ cynerd = {
+ desktop.enable = true;
+ develop = true;
+ gaming = true;
+ };
+
+ boot.initrd.availableKernelModules = ["nvme" "xhci_pci" "usb_storage"];
+ boot.kernelModules = ["kvm-amd"];
+ hardware.cpu.amd.updateMicrocode = true;
+
+ cynerd.autounlock = {
+ "encroot" = "/dev/disk/by-uuid/c07e929a-6eac-4f99-accf-f7cb3431290c";
+ "enchdd" = "/dev/disk/by-uuid/7fee3cda-efa0-47cd-8832-fdead9a7e6db";
+ };
fileSystems = {
"/" = {
- device = "/dev/disk/by-uuid/3b3063aa-c284-4075-bb37-8820df12a2f5";
+ device = "/dev/mapper/encroot";
options = ["compress=lzo" "subvol=@nix"];
};
"/home" = {
- device = "/dev/disk/by-uuid/3b3063aa-c284-4075-bb37-8820df12a2f5";
+ device = "/dev/mapper/encroot";
options = ["compress=lzo" "subvol=@home"];
};
"/boot" = {
@@ -21,11 +34,24 @@ with lib;
};
"/home2" = {
- device = "/dev/disk/by-uuid/c9aa0b7b-7482-4d4a-bcc3-8bd6a853ae7f";
+ device = "/dev/mapper/enchdd";
options = ["compress=lzo" "subvol=@home"];
};
};
+ services.syncthing = {
+ enable = true;
+ user = mkDefault "cynerd";
+ group = mkDefault "cynerd";
+ openDefaultPorts = true;
+
+ overrideDevices = false;
+ overrideFolders = false;
+
+ dataDir = "/home/cynerd";
+ configDir = "/home/cynerd/.config/syncthing";
+ };
+
};
}