aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/lipwig.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/lipwig.nix')
-rw-r--r--nixos/machine/lipwig.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/nixos/machine/lipwig.nix b/nixos/machine/lipwig.nix
new file mode 100644
index 0000000..aa3d448
--- /dev/null
+++ b/nixos/machine/lipwig.nix
@@ -0,0 +1,58 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = {
+ boot.isContainer = true;
+ boot.loader.initScript.enable = true;
+
+ cynerd.openvpn.enable = true;
+
+ # Git ######################################################################
+ services.gitolite = {
+ enable = false;
+ user = "git";
+ group = "git";
+ dataDir = "/var/lib/git";
+ adminPubkey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIaMmBV0wPvG5JQIWxi20IDlLokhRBumTEbUUD9TNWoY Bootstrap gitolite key";
+ };
+ services.gitDaemon = {
+ enable = false;
+ user = "gitdemon";
+ group = "gitdaemon";
+ basePath = "/var/lib/git/repositories";
+ };
+
+ # CalDAV and CardDAV #######################################################
+ services.radicale = {
+ enable = true;
+ settings = {
+ server = {
+ hosts = [ "0.0.0.0:5232" "[::]:5232" ];
+ ssl = true;
+ certificate = "/run/secrets/radicale/radicale.crt";
+ key = "/run/secrets/radicale/radicale.key";
+ };
+ encoding = {
+ request = "utf-8";
+ stock = "utf-8";
+ };
+ auth = {
+ type = "htpasswd";
+ htpasswd_filename = "/run/secrets/radicale/users";
+ htpasswd_encryption = "bcrypt";
+ delay = 1;
+ };
+ storage = {
+ filesystem_folder = "/var/lib/radicale/";
+ };
+ web = {
+ type = "none";
+ };
+ };
+ };
+ };
+
+}