aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/dean.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/dean.nix')
-rw-r--r--nixos/machine/dean.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/nixos/machine/dean.nix b/nixos/machine/dean.nix
index 3f449e3..b34bb0b 100644
--- a/nixos/machine/dean.nix
+++ b/nixos/machine/dean.nix
@@ -31,10 +31,15 @@ with lib;
dhcpcd.allowInterfaces = [ "brlan" ];
};
- swapDevices.swapfile = {
+ swapDevices = [{
device = "/var/swap";
priority = 1;
- };
+ }];
+
+ environment.systemPackages = with pkgs; [
+ openocd
+ sterm
+ ];
};