aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/dean.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/dean.nix')
-rw-r--r--nixos/machine/dean.nix31
1 files changed, 18 insertions, 13 deletions
diff --git a/nixos/machine/dean.nix b/nixos/machine/dean.nix
index aef3c04..8fca4bf 100644
--- a/nixos/machine/dean.nix
+++ b/nixos/machine/dean.nix
@@ -1,9 +1,10 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
{
-
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; {
config = {
cynerd = {
openvpn = {
@@ -15,23 +16,27 @@ with lib;
bridges = {
brlan = {
interfaces = [
- "eth0" "lan1" "lan2" "lan3" "lan4"
+ "eth0"
+ "lan1"
+ "lan2"
+ "lan3"
+ "lan4"
];
};
};
- dhcpcd.allowInterfaces = [ "brlan" ];
+ dhcpcd.allowInterfaces = ["brlan"];
};
- swapDevices = [{
- device = "/var/swap";
- priority = 1;
- }];
+ swapDevices = [
+ {
+ device = "/var/swap";
+ priority = 1;
+ }
+ ];
environment.systemPackages = with pkgs; [
#openocd
sterm
];
-
};
-
}