aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/dean.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-01-08 11:25:01 +0100
committerKarel Kočí <cynerd@email.cz>2023-01-08 11:25:01 +0100
commitd5dc7479c489d17e6dcacf081c0f1b5242d99bd9 (patch)
treec12d18231cacb81ff5b69a2073894d228e3c81e7 /nixos/machine/dean.nix
parentc7a226a92d65cedd384fa29083efdbb07a6084b0 (diff)
downloadnixos-personal-d5dc7479c489d17e6dcacf081c0f1b5242d99bd9.tar.gz
nixos-personal-d5dc7479c489d17e6dcacf081c0f1b5242d99bd9.tar.bz2
nixos-personal-d5dc7479c489d17e6dcacf081c0f1b5242d99bd9.zip
Format using Alejandra
Diffstat (limited to 'nixos/machine/dean.nix')
-rw-r--r--nixos/machine/dean.nix31
1 files changed, 18 insertions, 13 deletions
diff --git a/nixos/machine/dean.nix b/nixos/machine/dean.nix
index aef3c04..8fca4bf 100644
--- a/nixos/machine/dean.nix
+++ b/nixos/machine/dean.nix
@@ -1,9 +1,10 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
{
-
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; {
config = {
cynerd = {
openvpn = {
@@ -15,23 +16,27 @@ with lib;
bridges = {
brlan = {
interfaces = [
- "eth0" "lan1" "lan2" "lan3" "lan4"
+ "eth0"
+ "lan1"
+ "lan2"
+ "lan3"
+ "lan4"
];
};
};
- dhcpcd.allowInterfaces = [ "brlan" ];
+ dhcpcd.allowInterfaces = ["brlan"];
};
- swapDevices = [{
- device = "/var/swap";
- priority = 1;
- }];
+ swapDevices = [
+ {
+ device = "/var/swap";
+ priority = 1;
+ }
+ ];
environment.systemPackages = with pkgs; [
#openocd
sterm
];
-
};
-
}