aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/dean.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/dean.nix')
-rw-r--r--nixos/machine/dean.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/nixos/machine/dean.nix b/nixos/machine/dean.nix
new file mode 100644
index 0000000..eaa9094
--- /dev/null
+++ b/nixos/machine/dean.nix
@@ -0,0 +1,36 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = {
+ cynerd = {
+ openvpn = {
+ oldpersonal = true;
+ };
+ };
+
+ #boot.kernelPatches = [{
+ # name = "rwtm";
+ # patch = null;
+ # extraConfig = ''
+ # TURRIS_MOX_RWTM y
+ # ARMADA_37XX_RWTM_MBOX y
+ # '';
+ #}];
+
+ networking = {
+ bridges = {
+ brlan = {
+ interfaces = [
+ "eth0" "lan1" "lan2" "lan3" "lan4"
+ ];
+ };
+ };
+ dhcpcd.allowInterfaces = [ "brlan" ];
+ };
+
+ };
+
+}