aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/binky.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/binky.nix')
-rw-r--r--nixos/machine/binky.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/nixos/machine/binky.nix b/nixos/machine/binky.nix
index a90d625..3b3d35f 100644
--- a/nixos/machine/binky.nix
+++ b/nixos/machine/binky.nix
@@ -3,8 +3,9 @@
lib,
pkgs,
...
-}:
-with lib; {
+}: let
+ inherit (lib) mkDefault;
+in {
config = {
cynerd = {
desktop = {
@@ -20,8 +21,10 @@ with lib; {
};
};
- boot.initrd.availableKernelModules = ["nvme" "xhci_pci" "usb_storage" "sd_mod"];
- boot.kernelModules = ["kvm-amd"];
+ boot = {
+ initrd.availableKernelModules = ["nvme" "xhci_pci" "usb_storage" "sd_mod"];
+ kernelModules = ["kvm-amd"];
+ };
hardware.cpu.amd.updateMicrocode = true;