aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/binky.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/binky.nix')
-rw-r--r--nixos/machine/binky.nix114
1 files changed, 56 insertions, 58 deletions
diff --git a/nixos/machine/binky.nix b/nixos/machine/binky.nix
index a210a4b..569fccb 100644
--- a/nixos/machine/binky.nix
+++ b/nixos/machine/binky.nix
@@ -1,72 +1,70 @@
-{
- config,
- lib,
- pkgs,
- ...
-}: let
+{lib, ...}: let
inherit (lib) mkDefault;
in {
- config = {
- cynerd = {
- desktop = {
- enable = true;
- laptop = true;
- };
- wifiClient = true;
- develop = true;
- openvpn = {
- oldpersonal = true;
- elektroline = true;
- };
- };
+ deploy = {
+ enable = true;
+ default = false;
+ };
- boot = {
- initrd.availableKernelModules = ["nvme" "xhci_pci" "usb_storage" "sd_mod"];
- kernelModules = ["kvm-amd"];
+ cynerd = {
+ desktop = {
+ enable = true;
+ laptop = true;
+ };
+ wifiClient = true;
+ develop = true;
+ openvpn = {
+ oldpersonal = true;
+ elektroline = true;
};
+ };
+
+ boot = {
+ initrd.availableKernelModules = ["nvme" "xhci_pci" "usb_storage" "sd_mod"];
+ kernelModules = ["kvm-amd"];
+ };
- hardware.cpu.amd.updateMicrocode = true;
+ hardware.cpu.amd.updateMicrocode = true;
- boot.initrd.luks.devices = {
- "encroot".device = "/dev/disk/by-uuid/b317feb5-d68d-4ec3-a24f-0307c116cac8";
+ boot.initrd.luks.devices = {
+ "encroot".device = "/dev/disk/by-uuid/b317feb5-d68d-4ec3-a24f-0307c116cac8";
+ };
+ fileSystems = {
+ "/" = {
+ device = "/dev/mapper/encroot";
+ fsType = "btrfs";
+ options = ["compress=lzo" "subvol=@"];
};
- fileSystems = {
- "/" = {
- device = "/dev/mapper/encroot";
- fsType = "btrfs";
- options = ["compress=lzo" "subvol=@"];
- };
- "/nix" = {
- device = "/dev/mapper/encroot";
- fsType = "btrfs";
- options = ["compress=lzo" "subvol=@nix"];
- };
- "/home" = {
- device = "/dev/mapper/encroot";
- fsType = "btrfs";
- options = ["compress=lzo" "subvol=@home"];
- };
- "/boot" = {
- device = "/dev/disk/by-uuid/8F7D-A154";
- fsType = "vfat";
- };
+ "/nix" = {
+ device = "/dev/mapper/encroot";
+ fsType = "btrfs";
+ options = ["compress=lzo" "subvol=@nix"];
};
- services.btrfs.autoScrub = {
- enable = true;
- fileSystems = ["/"];
+ "/home" = {
+ device = "/dev/mapper/encroot";
+ fsType = "btrfs";
+ options = ["compress=lzo" "subvol=@home"];
};
+ "/boot" = {
+ device = "/dev/disk/by-uuid/8F7D-A154";
+ fsType = "vfat";
+ };
+ };
+ services.btrfs.autoScrub = {
+ enable = true;
+ fileSystems = ["/"];
+ };
- services.syncthing = {
- enable = true;
- user = mkDefault "cynerd";
- group = mkDefault "cynerd";
- openDefaultPorts = true;
+ services.syncthing = {
+ enable = true;
+ user = mkDefault "cynerd";
+ group = mkDefault "cynerd";
+ openDefaultPorts = true;
- overrideDevices = false;
- overrideFolders = false;
+ overrideDevices = false;
+ overrideFolders = false;
- dataDir = "/home/cynerd";
- configDir = "/home/cynerd/.config/syncthing";
- };
+ dataDir = "/home/cynerd";
+ configDir = "/home/cynerd/.config/syncthing";
};
}