aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/albert.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/albert.nix')
-rw-r--r--nixos/machine/albert.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nixos/machine/albert.nix b/nixos/machine/albert.nix
new file mode 100644
index 0000000..0adad68
--- /dev/null
+++ b/nixos/machine/albert.nix
@@ -0,0 +1,31 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = {
+ cynerd.desktop.enable = true;
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/1c9bafac-fcf8-41c4-b394-bca5917ca82d";
+ options = ["compress=lzo" "subvol=@nix"];
+ };
+ "/home" = {
+ device = "/dev/disk/by-uuid/1c9bafac-fcf8-41c4-b394-bca5917ca82d";
+ options = ["compress=lzo" "subvol=@home"];
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/E403-124B";
+ };
+
+ "/home2" = {
+ device = "/dev/disk/by-uuid/55e177a1-215e-475b-ba9c-771b5fa3f8f0";
+ options = ["compress=lzo" "subvol=@home"];
+ };
+ };
+
+ };
+
+}