aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/adm-omnia2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/adm-omnia2.nix')
-rw-r--r--nixos/machine/adm-omnia2.nix72
1 files changed, 32 insertions, 40 deletions
diff --git a/nixos/machine/adm-omnia2.nix b/nixos/machine/adm-omnia2.nix
index 2573372..be245e2 100644
--- a/nixos/machine/adm-omnia2.nix
+++ b/nixos/machine/adm-omnia2.nix
@@ -1,47 +1,39 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib; {
- config = {
- cynerd = {
- switch = {
- enable = true;
- lanAddress = "${config.cynerd.hosts.adm.omnia2}/24";
- lanGateway = config.cynerd.hosts.adm.omnia;
- };
- wifiAP.adm = {
- enable = true;
- ar9287.interface = "wlp2s0";
- qca988x.interface = "wlp1s0";
- };
+{config, ...}: {
+ cynerd = {
+ switch = {
+ enable = true;
+ lanAddress = "${config.cynerd.hosts.adm.omnia2}/24";
+ lanGateway = config.cynerd.hosts.adm.omnia;
};
-
- services.btrfs.autoScrub = {
+ wifiAP.adm = {
enable = true;
- fileSystems = ["/"];
+ ar9287.interface = "wlp2s0";
+ qca988x.interface = "wlp1s0";
};
+ };
- networking = {
- useNetworkd = true;
- useDHCP = false;
- };
- systemd.network.networks = {
- "lan-brlan" = {
- matchConfig.Name = "lan* eth0";
- networkConfig.Bridge = "brlan";
- bridgeVLANs = [
- {
- bridgeVLANConfig = {
- EgressUntagged = 1;
- PVID = 1;
- };
- }
- {bridgeVLANConfig.VLAN = 2;}
- ];
- };
+ services.btrfs.autoScrub = {
+ enable = true;
+ fileSystems = ["/"];
+ };
+
+ networking = {
+ useNetworkd = true;
+ useDHCP = false;
+ };
+ systemd.network.networks = {
+ "lan-brlan" = {
+ matchConfig.Name = "lan* eth0";
+ networkConfig.Bridge = "brlan";
+ bridgeVLANs = [
+ {
+ bridgeVLANConfig = {
+ EgressUntagged = 1;
+ PVID = 1;
+ };
+ }
+ {bridgeVLANConfig.VLAN = 2;}
+ ];
};
};
}