aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/adm-mpd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/adm-mpd.nix')
-rw-r--r--nixos/machine/adm-mpd.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/nixos/machine/adm-mpd.nix b/nixos/machine/adm-mpd.nix
new file mode 100644
index 0000000..3e103e1
--- /dev/null
+++ b/nixos/machine/adm-mpd.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = {
+ fileSystems = {
+ "/" = {
+ device = "/dev/mmcblk0p2";
+ options = ["compress=lzo" "subvol=@nix"];
+ };
+ "/home" = {
+ device = "/dev/mmcblk0p2";
+ options = ["compress=lzo" "subvol=@home"];
+ };
+ "/boot" = {
+ device = "/dev/mmcblk0p1";
+ };
+ };
+ };
+
+}