aboutsummaryrefslogtreecommitdiff
path: root/nixos/configurations/spt-omniax.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configurations/spt-omniax.nix')
-rw-r--r--nixos/configurations/spt-omniax.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/nixos/configurations/spt-omniax.nix b/nixos/configurations/spt-omniax.nix
new file mode 100644
index 0000000..4f9e0e0
--- /dev/null
+++ b/nixos/configurations/spt-omniax.nix
@@ -0,0 +1,51 @@
+{
+ turris.board = "omnia";
+
+ cynerd = {
+ router = {
+ enable = true;
+ wan = "end2";
+ lanIP = "192.168.2.1";
+ };
+ wifiAP.spt = {
+ enable = true;
+ ar9287.interface = "wlp3s0";
+ qca988x.interface = "wlp2s0";
+ };
+ monitoring.speedtest = true;
+ };
+
+ networking.useDHCP = false;
+ systemd.network = {
+ networks = {
+ "end2" = {
+ matchConfig.Name = "end2";
+ networkConfig = {
+ BindCarrier = "end2";
+ DHCP = "yes";
+ IPv6AcceptRA = "yes";
+ DHCPPrefixDelegation = "yes";
+ };
+ dhcpPrefixDelegationConfig = {
+ UplinkInterface = ":self";
+ SubnetId = 0;
+ Announce = "no";
+ };
+ linkConfig.RequiredForOnline = "routable";
+ };
+ "lan-brlan" = {
+ matchConfig.Name = "lan*";
+ networkConfig.Bridge = "brlan";
+ bridgeVLANs = [
+ {
+ bridgeVLANConfig = {
+ EgressUntagged = 1;
+ PVID = 1;
+ };
+ }
+ {bridgeVLANConfig.VLAN = 2;}
+ ];
+ };
+ };
+ };
+}