aboutsummaryrefslogtreecommitdiff
path: root/nixos/configurations/spt-omnia.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configurations/spt-omnia.nix')
-rw-r--r--nixos/configurations/spt-omnia.nix21
1 files changed, 13 insertions, 8 deletions
diff --git a/nixos/configurations/spt-omnia.nix b/nixos/configurations/spt-omnia.nix
index 22d9ecc..29fe8c4 100644
--- a/nixos/configurations/spt-omnia.nix
+++ b/nixos/configurations/spt-omnia.nix
@@ -88,7 +88,10 @@ in {
users = {
nas = {
group = "nas";
- openssh.authorizedKeys.keyFiles = [(config.personal-secrets + "/unencrypted/nas.pub")];
+ openssh.authorizedKeys.keyFiles = [
+ (config.personal-secrets + "/unencrypted/nas.pub")
+ (config.personal-secrets + "/unencrypted/nas-spt.pub")
+ ];
isNormalUser = true;
home = "/data/nas";
homeMode = "770";
@@ -135,8 +138,12 @@ in {
DHCP = "ipv6";
IPv6AcceptRA = "no";
DHCPPrefixDelegation = "yes";
+ DNS = "1.1.1.1";
+ };
+ dhcpV6Config = {
+ PrefixDelegationHint = "::/56";
+ UseDNS = "no";
};
- dhcpV6Config.PrefixDelegationHint = "::/56";
dhcpPrefixDelegationConfig = {
UplinkInterface = ":self";
SubnetId = 0;
@@ -149,12 +156,10 @@ in {
networkConfig.Bridge = "brlan";
bridgeVLANs = [
{
- bridgeVLANConfig = {
- EgressUntagged = 1;
- PVID = 1;
- };
+ EgressUntagged = 1;
+ PVID = 1;
}
- {bridgeVLANConfig.VLAN = 2;}
+ {VLAN = 2;}
];
};
};
@@ -170,7 +175,7 @@ in {
lcp-echo-adaptive
defaultroute
defaultroute6
- usepeerdns
+ #usepeerdns
maxfail 1
user metronet
password metronet