aboutsummaryrefslogtreecommitdiff
path: root/nixos/configurations/lipwig.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configurations/lipwig.nix')
-rw-r--r--nixos/configurations/lipwig.nix98
1 files changed, 93 insertions, 5 deletions
diff --git a/nixos/configurations/lipwig.nix b/nixos/configurations/lipwig.nix
index e6ec96a..524a864 100644
--- a/nixos/configurations/lipwig.nix
+++ b/nixos/configurations/lipwig.nix
@@ -33,6 +33,10 @@
"/nas" = {
device = "172.16.128.63:/nas/2682";
fsType = "nfs";
+ options = [
+ "_netdev"
+ "x-systemd.automount"
+ ];
};
"/nas/nextcloud-sync" = {
device = "/nas/sync";
@@ -43,12 +47,11 @@
device = "nas@omnia.spt:/data/nas";
fsType = "fuse.sshfs";
options = [
- "noauto"
- "x-systemd.automount"
+ "allow_other"
"_netdev"
+ "x-systemd.automount"
"reconnect"
"identityfile=/run/secrets/nas.ssh.priv"
- "allow_other"
"idmap=user"
"uid=nextcloud"
"gid=nextcloud"
@@ -104,8 +107,8 @@
root = "${pkgs.cgit}/cgit";
locations."/".tryFiles = "$uri @cgit";
locations."@cgit".extraConfig = ''
- fastcgi_param SCRIPT_FILENAME ${pkgs.cgit}/cgit/cgit.cgi;
fastcgi_pass unix:${config.services.fcgiwrap.socketAddress};
+ fastcgi_param SCRIPT_FILENAME ${pkgs.cgit}/cgit/cgit.cgi;
fastcgi_param PATH_INFO $uri;
fastcgi_param QUERY_STRING $args;
fastcgi_param HTTP_HOST $server_name;
@@ -124,6 +127,14 @@
proxyWebsockets = true;
};
};
+ "searx.cynerd.cz" = {
+ forceSSL = true;
+ useACMEHost = "cynerd.cz";
+ locations."/".extraConfig = ''
+ uwsgi_pass "unix:///run/searx/searx.sock";
+ include ${config.services.nginx.package}/conf/uwsgi_params;
+ '';
+ };
};
};
services.fcgiwrap = {
@@ -134,9 +145,10 @@
acceptTerms = true;
defaults.email = "cynerd+acme@email.cz";
certs."cynerd.cz".extraDomainNames = [
- "git.cynerd.cz"
"cloud.cynerd.cz"
+ "git.cynerd.cz"
"grafana.cynerd.cz"
+ "searx.cynerd.cz"
];
};
@@ -267,6 +279,82 @@
ensureDatabases = ["nextcloud"];
};
+ # SearX ####################################################################
+ services.searx = {
+ enable = true;
+ environmentFile = "/run/secrets/searx.env";
+ settings = {
+ server.secret_key = "@SEARX_SECRET_KEY@";
+ search = {
+ autocomplete = "google";
+ autocomplete_min = 2;
+ };
+ ui = {
+ query_in_title = true;
+ infinite_scroll = true;
+ center_alignment = true;
+ hotkeys = "vim";
+ };
+ engines = [
+ {
+ name = "seznam";
+ disabled = false;
+ }
+ {
+ name = "material icons";
+ disabled = false;
+ }
+ {
+ name = "svgrepo";
+ disabled = false;
+ }
+ {
+ name = "peertube";
+ disabled = false;
+ }
+ {
+ name = "lib.rs";
+ disabled = false;
+ }
+ {
+ name = "gitlab";
+ disabled = false;
+ }
+ {
+ name = "sourcehut";
+ disabled = false;
+ }
+ {
+ name = "free software directory";
+ disabled = false;
+ }
+ {
+ name = "cppreference";
+ disabled = false;
+ }
+ {
+ name = "searchcode code";
+ disabled = false;
+ }
+ {
+ name = "imdb";
+ disabled = false;
+ }
+ {
+ name = "tmdb";
+ disabled = false;
+ }
+ ];
+ };
+ runInUwsgi = true;
+ uwsgiConfig = {
+ socket = "/run/searx/searx.sock";
+ chmod-socket = "660";
+ };
+ redisCreateLocally = true;
+ };
+ users.groups.searx.members = ["nginx"];
+
# Old Syncthing ############################################################
services.syncthing = {
enable = true;