aboutsummaryrefslogtreecommitdiff
path: root/nixos/configurations/albert.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configurations/albert.nix')
-rw-r--r--nixos/configurations/albert.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/nixos/configurations/albert.nix b/nixos/configurations/albert.nix
new file mode 100644
index 0000000..a6a4ee1
--- /dev/null
+++ b/nixos/configurations/albert.nix
@@ -0,0 +1,41 @@
+{
+ nixpkgs.hostPlatform.system = "x86_64-linux";
+
+ cynerd = {
+ desktop = {
+ enable = true;
+ laptop = true;
+ };
+ wifiClient = true;
+ openvpn = {
+ oldpersonal = true;
+ };
+ };
+
+ boot.initrd.availableKernelModules = ["xhci_pci" "usb_storage" "sd_mod"];
+
+ hardware.cpu.intel.updateMicrocode = true;
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/1c9bafac-fcf8-41c4-b394-bca5917ca82d";
+ fsType = "btrfs";
+ options = ["compress=lzo" "subvol=@nix"];
+ };
+ "/home" = {
+ device = "/dev/disk/by-uuid/1c9bafac-fcf8-41c4-b394-bca5917ca82d";
+ fsType = "btrfs";
+ options = ["compress=lzo" "subvol=@home"];
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/E403-124B";
+ fsType = "vfat";
+ };
+
+ "/home2" = {
+ device = "/dev/disk/by-uuid/55e177a1-215e-475b-ba9c-771b5fa3f8f0";
+ fsType = "btrfs";
+ options = ["compress=lzo" "subvol=@home"];
+ };
+ };
+}